Language Translation

From Mumble Wiki
Revision as of 03:39, 23 February 2009 by PatPeter (talk | contribs) (LanguageTranslation moved to Language Translation: Space for uniformity to other Wiki pages)
Jump to: navigation, search

Mumble Languages

Mumble currently (as of November 29, 2008) supports ten different languages. As more people use Mumble, more languages must be added. If you know another language that is not one of the eight that are currently supported (even if you know one of the eight you can still be beneficial, as more features are added/changed to Mumble the text for them must be revised or changed) read this guide on how to add language support to Mumble.

What You Should Know

If you are planning on translating a language, please make sure and accurately translate it completely, and when it is added to Mumble, run Mumble and check over all the text, ensuring that it is accurately and properly translated, and that there is no text overlapping/incorrectly formatted. If it has any of these problems then revise the text and resubmit it. However, please at least double check the language before submitting it.

Getting Started

If you are running Windows then go here. Download linguist.exe and put it in your C:\Program Files\Mumble directory. If you are running Linux you will need the Qt Development kit (you need the Qt Linguist program that comes with it). You can find it here. You can manually compile it but this is much faster. It is also suggested that you peruse this guide to Qt Linguist before continuing with this guide. Please note if you are using Linux you must adapt this guide to all equivalent Linux related commands and procedures.

You will now need the default Mumble ts file. You can find it here. (Right click mumble_en.ts and click "Save Link As..."). Put this on your Desktop or in a convenient location. Remember that this file will change as new versions of Mumble are released. Make sure that you get the latest file each time you go to translate. Once you have a translated language that has been added to Mumble, and you want to translate, revise, or add new content because of subsequent additions in features to Mumble, find your language file here (scroll down to the bottom of this page) and use it as the base for the changes to the language file.

Go to C:\Program Files\Mumble and find linguist.exe. Double click it and the program should start. (I recommend making a shortcut on your Desktop to Qt Linguist to speed up the process.) Now click File -> Open... and select the ts file you downloaded from the last step. First, click Edit -> Translation File Settings... In the first dropdown menu select the language that you are translating to. Now just click on each entry on the left and edit the translated language entry to the language you know. There are various mechanisms that aid you in the translations and these are explained in the Qt Linguist guide. When you save the file make sure to name it in the language you are translating to. For instance if you were translating to Russian you would save the file as "mumble_ru.ts".

Remember, translations a slow, precise work and require much translation effort. You do not need ANY coding skills in order to translate Mumble however, just time and patience. Take at least a couple of days to make sure you have accurately translated each section. You can periodically save it and come back to it of course. If you come to a word or phrase that cannot be accurately translated, please leave it in the default english language, if an entire entry cannot be translated correctly, just leave that particular entry blank. When you are done with the entire translation, click File -> Save.

Testing The Results

The language file can now be tested. Open your language file in Linguist and do File -> Release As... then save it to your Desktop. You should now have mumble_*.qm. Go to your Mumble folder and put the mumble_*.qm (where * is the abbreviation of the language you are translating, for instance if it was Polish you were translating to it would be mumble_pl.qm) file inside of it. Now start Mumble and make sure that your language is set for "System default" in the user interface section of the Mumble configuration. Windows should also be set to use the language you are translating. The language should be displayed in Mumble when you start/restart Mumble.

Submitting The File

Submit the file that you translated (mumble_*.ts) here. Archive your ts file (bzip, gz or the like are preferred, but you can use whichever is the easiest for you) and attach it to the post. On the title put <language you have translated> Translation. The Mumble developers will take your translation file and add it to Mumble. Remember, do not submit the file as a compiled .qm file, as the Mumble developers cannot properly use this type of file.